Services impacted by AWS issues

Incident Report for Eastern Michigan University I.T.

Resolved

All affected service providers are reporting the performance issues as resolved.
Posted Oct 20, 2025 - 19:40 EDT

Update

AWS continues to work on recovery of their services. Ellucian and Zoom have also reported degraded service related to the AWS issues.
Posted Oct 20, 2025 - 16:20 EDT

Investigating

Service issues within the AWS hosting infrastructure (https://health.aws.amazon.com/health/status) are causing performance issues for a number of hosted services. Currently, Canvas (https://status.instructure.com/) is the only known Eastern Michigan University provider affected.
Posted Oct 20, 2025 - 09:50 EDT
This incident affected: my.emich.edu and Student and Faculty Services (Canvas).