Canvas outage

Incident Report for Eastern Michigan University I.T.

Resolved

This incident has been resolved.
Posted May 08, 2026 - 14:37 EDT

Monitoring

Canvas is back online and we are monitoring its status.
Posted May 07, 2026 - 22:45 EDT

Investigating

We have received notification from Instructure that Canvas is currently unavailable. We are monitoring this issue. You can follow Instructure's updates at status.instructure.com.
Posted May 07, 2026 - 17:21 EDT
This incident affected: Student and Faculty Services (Canvas).