Network Instability - King, Roosevelt, McKenny

Incident Report for Eastern Michigan University I.T.

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 15:29 EDT

Monitoring

A fix has been implemented, and we will continue to monitor.
Posted Jul 17, 2026 - 12:40 EDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Jul 17, 2026 - 12:12 EDT

Investigating

We're observing a network issue that is affecting network stability in King, Roosevelt, and McKenny. We are currently investigating further.
Posted Jul 17, 2026 - 09:24 EDT
This incident affected: Network Services (WiFi Network, Wired Network).