Campus Internet Connectivity

Incident Report for Eastern Michigan University I.T.

Resolved

Internet connectivity has been fully restored. This incident is now resolved.
Posted Oct 18, 2025 - 20:07 EDT

Monitoring

The issue has been found, and a fix has been implemented. We will continue to monitor.
Posted Oct 18, 2025 - 18:05 EDT

Update

We are continuing to investigate this issue. Merit Network engineers are also investigating the issue, which appears to also be impacting WCC and AAPS.
Posted Oct 18, 2025 - 17:40 EDT

Investigating

We have received reports that internet connectivity to campus resources is unreliable. We are investigating the issue.
Posted Oct 18, 2025 - 15:44 EDT
This incident affected: Network Services (Campus Internet Link).